SourceTec Software

It is currently Sat Apr 19, 2014 11:02 am

All times are UTC + 8 hours




Post new topic Reply to topic  [ 26 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Mon Jul 18, 2011 4:02 am 
Offline
Poster

Joined: Mon Sep 11, 2006 5:25 am
Posts: 30
One last desparate gasp. Maybe the website I was putting the scroller on had something about it - maybe the sjc had a fault - maybe something so I really started from scratch. I made a brand new scroller but used the same setup settings throughout that I had on the old one but for adding a picture(logo) or two more - so it would look the same (no scroll arrows for example).
I went to another website that is really only used by me and that only has a index page with some text on it and no fancy stuff - not even graphics and made a new blank page. It is at http://sechelt.info/page2.html
I put in the header code but modified it only by using the full website address - I put in the page code again just putting in the website address in full. I posted it. Nothing.
On the page then I have put a bunch of links to zip files. Screen shots of the html souce code - screen shots of the FTP setup - the entire folder that is posted and includes the images and js - the sjc or source file. That is all there is or could be but it does not work.
Since I had some moderate success with this program on a couple of other sites in the past and also was able to succeed with the simple iPad01 then I can only figure there is something wrong with this particualr template or the setting I use do something.
I have no idea what more I can try. :cry:


Top
 Profile  
 
PostPosted: Mon Jul 18, 2011 4:36 am 
Offline
Old Hand
User avatar

Joined: Wed Jul 05, 2006 5:27 am
Posts: 130
Location: Crossett, Arkansas U.S.A.
I went to the folder where you pointed and looked for "scroller1.js" and it isn't there. If you are going to look for that file, it must be there or you will be getting errors

=======================================

Index of http://www.sechelt.info//ScrollSpon/js

Parent Directory
scroller.js
stscode.js
stseff.js

Apache Server at sechelt.info Port 80

========================================

Now, if you look at your images and compare what you have to what I have written, you will see where you made your mistake:

Pasted to head: <script type="text/javascript" src="http://www.sechelt.info/ScrollSpon/js/stscode.js"></script> --- This one was okay.

Pasted to body: <script type="text/javascript" src="http://www.sechelt.info/ScrollSpon/js/scroller.js"></script> ---

Your version was quite a bit different with errors: <script type="<script type="text/javascript" src="http://www.sechelt.info/ScrollSpon/js/scroller1.js"></script>

Here are the errors:

You put "<script type= twice in the body . . . on the same line . . . and you pointed your browser to look for /ScrollSpon/js/scroller1.js --- which does not exist on your server.

New page created today http://www.ahgweb.com/demo

It points to YOUR server and YOUR folders and YOUR scroller.js file. Please take a look.

You must be doing this when you're tired like I do sometimes . . . takes a few times doing it correctly to make it work every time.

Jolt Cola or Coffee?


Top
 Profile  
 
PostPosted: Mon Jul 18, 2011 6:52 am 
Offline
Poster

Joined: Mon Sep 11, 2006 5:25 am
Posts: 30
You're right I am getting tired of this and no doubt you are too. I have redone http://sechelt.info/page2.html and you can see the result. Away back when with support I went thought this same result - a scroller with no images. They never gave me any answer and I think that software should require less none documented functions(using the full web address is not suggested anywhere for example and so on)
I checked the entries in the source code of your page and my revised one and:
BODY CODE
Source at ahgweb -- <script type="text/javascript" src="http://www.sechelt.info/ScrollSpon/js/scroller.js"></script>
Source at sechelt -- <script type="text/javascript" src="http://www.sechelt.info/ScrollSpon/js/scroller.js"></script>

HEADER
Source at ahgweb -- <script type="text/javascript" src="http://www.sechelt.info/ScrollSpon/js/stscode.js"></script>
Source at sechelt -- <script type="text/javascript" src="http://www.sechelt.info/ScrollSpon/js/stscode.js"></script>

For the life of me I cannot see the difference but yours works and mine does not.


Top
 Profile  
 
PostPosted: Mon Jul 18, 2011 7:33 am 
Offline
Old Hand
User avatar

Joined: Wed Jul 05, 2006 5:27 am
Posts: 130
Location: Crossett, Arkansas U.S.A.
May be the way the code is written by your html program.

Here is the entire page for the working version::

================================================================

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<meta name="Generator" content="Serif WebPlus X4 (12.0.5.033)">
<title>Home</title>
<script type="text/javascript" src="http://www.sechelt.info/ScrollSpon/js/stscode.js"></script>
<style type="text/css">
<!--
body {margin: 0px; padding: 0px;}
a:link {color: #2c3651;}
a:visited {color: #1f5b8b;}
a:hover {color: #2c3651;}
a:active {color: #2c3651;}
-->
</style>
</head>

<body text="#000000" style="background-color:#ffffff; text-align:center; height:1000px;">
<div style="background-color:transparent;text-align:left;margin-left:auto;margin-right:auto;position:relative;width:750px;height:1000px;">
<div style="position:absolute; left:61px; top:59px; width:239px; height:247px;">
<div id="frag_1" style="text-align:left;">
<script type="text/javascript" src="http://www.sechelt.info/ScrollSpon/js/scroller.js"></script>
</div></div>
</div>
</body>
</html>

==================================================================

See if that works on your server.


Top
 Profile  
 
PostPosted: Mon Jul 18, 2011 7:38 am 
Offline
Old Hand
User avatar

Joined: Wed Jul 05, 2006 5:27 am
Posts: 130
Location: Crossett, Arkansas U.S.A.
another way I have found success in using the scroller is in a "framed document" (iframe: inline frame).

I create a simple html page that does nothing but display the scroller, and load that page in the iframe.


=================================================
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html lang="en">
<head>
<script type="text/javascript" src="http://www.sechelt.info/ScrollSpon/js/stscode.js"></script>
</head>

<body>
<script type="text/javascript" src="http://www.sechelt.info/ScrollSpon/js/scroller.js"></script>
</body>
</html>
==================================================


Top
 Profile  
 
PostPosted: Mon Jul 18, 2011 8:14 am 
Offline
Poster

Joined: Mon Sep 11, 2006 5:25 am
Posts: 30
This has gone on for months with the support and now days with you. Thank you. I am going to the authors of the html writer I use - Virtual Mechanics SiteSpinner - and take it up with them. At least I spread the misery.
Thanks for all you work and patience.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 26 posts ]  Go to page Previous  1, 2

All times are UTC + 8 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group