SourceTec Software

It is currently Wed Apr 23, 2014 6:04 pm

All times are UTC + 8 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Tue Apr 10, 2012 6:50 am 
Offline
Member

Joined: Tue Apr 10, 2012 5:46 am
Posts: 4
Location: USA
I'm new to SWF Quicker, but I'm a fairly experienced Actionscript developer. I'm trying to use a symbol linkage to connect some custom classes to a Movieclip symbol in my library, but I just can't seem to make it work.

I have two classes in the source code: scaleform.clik.controls.Button and scaleform.clik.core.UIComponent. These come from the CLIK user interface tools from Scaleform for the Unreal Development Kit. Button extends UIComponent which extends the native flash.display.MovieClip. In the linkage for my symbol, my class is set to scaleform.clik.controls.Button, and the base class is set to scaleform.clik.core.UIComponent. The scaleform directory is in a directory called CLIK, which is included in my source path in the Actionscript 3.0 Common settings (in the Tools->Options menu item) as well as the source path in the Actionscript 3.0 publish settings.

I can't understand why this doesn't work, but I keep getting the error: "The definition of base class UIComponent was not found." Does anyone have any ideas of what I might be missing? Is SWF Quicker capable of implementing custom classes like this?


Top
 Profile  
 
PostPosted: Tue Sep 17, 2013 12:22 am 
Offline
Member

Joined: Mon Sep 16, 2013 10:55 pm
Posts: 1
I'm having the exact same problem and I can solving it.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC + 8 hours


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group