SourceTec Software

It is currently Thu Apr 24, 2014 1:54 am

All times are UTC + 8 hours




Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Fri Dec 21, 2012 3:02 am 
Offline
Member

Joined: Mon Sep 20, 2010 11:23 pm
Posts: 5
Hi all!

I'm having a hard and long battle with a issue regarding the popup menu. It works fine with IE but with chrome it's not showing properly!
Here's the site i'm building: http://www.mozambicar.tk
As you can see there... the sothink menu is the one with the vehicle brands. At each brand a mouseover change the brand icon and popsup a popup menu as an image. The problem that it the popup should be centered (as in IE). In Chrome the popup ain't centered... the popupmenu pops at the left of the screen.

Is there any solution?

Thankyou!


Top
 Profile  
 
PostPosted: Fri Dec 21, 2012 8:05 am 
Offline
Guru
User avatar

Joined: Mon May 10, 2004 3:53 am
Posts: 1752
Location: Rescue, CA, USA
It looks as if it might be a problem with your CSS. Try "commenting out" your stylesheet or stylesheet link. If that eliminates the problem with your menu, it will take some detective work to determine which stylesheet specification is causing the problem. Table tags in a stylesheet can cause problems because DHTML Menu uses tables internally. Also, look for a universal selector (represented by an asterisk *). They can cause problems.

Happy Holidays!

Bill
Unofficial DHTML Menu Resource Site


Top
 Profile  
 
PostPosted: Fri Dec 21, 2012 4:46 pm 
Offline
Member

Joined: Mon Sep 20, 2010 11:23 pm
Posts: 5
Hi Bill_P

First, thank for your reply! :)
This menu is made with DHTML menu... but the rest of the website is with Webplus X6. The scripts that are created include some individual .css (from other webplus menus) and a wpstyle.css (which, i think, doesn't include nothing about sothink's menu). But here it goes:

[code]
a:link {color:#2c3651;}
a:visited {color:#1f5b8b;}
a:hover {color:#2c3651;}
a:active {color:#2c3651;}
.Wp-Artistic-Body-P
{
margin:0.0px 0.0px 0.0px 0.0px; text-align:left; font-weight:400;
}
.Wp-Body-P
{
margin:0.0px 0.0px 12.0px 0.0px; text-align:left; font-weight:400;
}
.Wp-MOZ_Corpo-P
{
margin:0.0px 0.0px 3.0px 0.0px; text-align:left; font-weight:400;
}
.Wp-Normal-P
{
margin:0.0px 0.0px 0.0px 0.0px; text-align:left; font-weight:400;
}
.Wp-moz_corpo-p-P
{
margin:0.0px 7.0px 3.0px 0.0px; text-align:justify; font-weight:400; text-indent:8.0px;
}
.Wp-Default-Paragraph-Font-C
{
font-family:"Verdana", sans-serif;
}
.Wp-gt-icon-text1-c1-C
{
font-family:"Arial", sans-serif;
}
.Wp-moz_corpo-c1-C
{
font-family:"Arial", sans-serif; font-weight:700;
}
[/code]
Can't manage to activate BBCode (sorry).

Thank you!

EDIT: I've uploaded the scripts that webplus creates from the full website.
http://www.datafilehost.com/download-ed2eb702.html


Top
 Profile  
 
PostPosted: Fri Dec 21, 2012 11:27 pm 
Offline
Guru
User avatar

Joined: Mon May 10, 2004 3:53 am
Posts: 1752
Location: Rescue, CA, USA
Please post the PGT file for the menu.

Regards,

Bill
Unofficial DHTML Menu Resource Site


Top
 Profile  
 
PostPosted: Sun Dec 23, 2012 3:22 am 
Offline
Member

Joined: Mon Sep 20, 2010 11:23 pm
Posts: 5
Here it goes!

http://www.datafilehost.com/download-f75b0ac0.html

Thank you Bill_P for helping me!
Regards
Filipe


Top
 Profile  
 
PostPosted: Sun Dec 23, 2012 8:58 am 
Offline
Guru
User avatar

Joined: Mon May 10, 2004 3:53 am
Posts: 1752
Location: Rescue, CA, USA
Hi Filipe,

Thank you for providing the .pgt file for your menu. I generated a menu using your .pgt file (without images) and inserted it in a sample web page at:

Example removed.

The dropdown menus appear to be centered in current versions of IE and Chrome so the problem is not with your menu. Instead, the problem appears to be with the method used for page layout. I'm not sure that this will fix the problem but try the following. The line immediately preceding the menu code currently reads as follows:
Code:
<div id="frag_14" style="position:absolute;left:12px;top:128px;width:129px;height:51px;">

Change the word absolute to relative so that the line reads as follows:
Code:
<div id="frag_14" style="position:relative;left:12px;top:128px;width:129px;height:51px;">

If my suggestion doesn't fix the problem, the Serif forum at http://forums.serif.com/forumdisplay.php?f=13 might be a better resource for help with the problem.

Regards,

Bill
Unofficial DHTML Menu Resource Site


Top
 Profile  
 
PostPosted: Sun Dec 23, 2012 8:39 pm 
Offline
Member

Joined: Mon Sep 20, 2010 11:23 pm
Posts: 5
Damn Bill_P... you did it! It's working!
I can thank you enough for your enormous help (for some time i was trying to solve this... always think it was a more complex problem or bug).
It's very good to know that there are people like you that are there to help.
I'll be in touch with your site too! (already solved me the problem with the IE10 :) )
Tommorow i'll update the site!

Thank you!
Filipe


Top
 Profile  
 
PostPosted: Sun Dec 23, 2012 11:38 pm 
Offline
Guru
User avatar

Joined: Mon May 10, 2004 3:53 am
Posts: 1752
Location: Rescue, CA, USA
You're welcome, Filipe, I'm glad I was able to help.

Feliz Natal e Feliz Ano Novo!

Bill
Unofficial DHTML Menu Resource Site


Top
 Profile  
 
PostPosted: Mon Dec 24, 2012 5:51 am 
Offline
Member

Joined: Mon Sep 20, 2010 11:23 pm
Posts: 5
You're a good guy Bill_P! Thank you! Feliz Natal para ti também! :)
Have a good Christmas and a very good New Year!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC + 8 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group